guix-dotfiles/home-config/nix-home-manager/flake.nix

41 lines
1.1 KiB
Nix

{
description = "Home Manager configuration of ryan";
inputs = {
# Specify the source of Home Manager and Nixpkgs.
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
home-manager = {
url = "github:nix-community/home-manager";
inputs.nixpkgs.follows = "nixpkgs";
};
hyprpicker-git = {
url = "github:hyprwm/hyprpicker";
inputs.nixpkgs.follows = "nixpkgs";
};
};
outputs = { nixpkgs, home-manager, hyprpicker-git, ... }@inputs:
let
system = "x86_64-linux";
pkgs = nixpkgs.legacyPackages.${system};
overlays = [
hyprpicker-git.overlays.default
];
in {
homeConfigurations."ryan" = home-manager.lib.homeManagerConfiguration {
inherit pkgs;
# Specify your home configuration modules here, for example,
# the path to your home.nix.
modules = [
./home.nix
{nixpkgs.overlays = overlays;}
];
# Optionally use extraSpecialArgs
# to pass through arguments to home.nix
#extraSpecialArgs = { inherit inputs; };
};
};
}